Jump to content



Recommended Posts

Hi. We have a 2005 Mountaineer 5th wheel. When I went to turn the AC on the other day nothing happened. No fan or AC. Tried just fan only and nothing. Tried the furnance and nothing. The thermostat is a Duo Therm 3107541.009. 120v is good thru circuit breaker. On the Thermostat the dc volts are good at the fan,hi fan cool,and furnace. I read where jumpering from fan lug to grd lug should make the fan work and nothing happen when jumpered. Anyone have any idea what is common to all three (the furnace, ac, & fan only). It's been quite a while since the furnace has been on so maybe it's 2 different problems. Thanks for any suggestions. Tom

Link to comment
Share on other sites

I did a search based upon your "Duo Therm 3107541.009" and I found nothing at all. I have a spare thermostat of the 3106 series and have trouble shot those more than once. It is the one shown below. I do have some technical information on it.




The second picture is of what is called a "Five Button Comfort Control Center" and if you click on that link it will take you to a trouble shooting guide for that model. There is also a Dometic website which has some manuals available there. If you could post a picture of the one that you have, it may be helpful.


I would assume that you have a Dometic air conditioner since your thermostat is from them? It is important to realize that with these thermostats that control both the air conditioner and the furnace, as well as possibly a heat pump and sometimes heat strips, they all have a control circuit board that is inside of the air conditioner and it gets all signals from the thermostat and then sends that signal to the proper part of the air conditioner or to the furnace. The actual operation varies quite widely from one thermostat to the next and to a lesser degree the air conditioner involved. The control circuit board in the air conditioner depends upon what thermostat it is mated to. I have replaced more than one defective thermostat, one a/c control circuit board, and assorted other problems in the RVs of friends and neighbors, as well as a our own RVs over the years.


Some of the thermostats do have an internal fuse, and sometimes there is one on the control circuit board. It never hurts to check for fuses when you have problems but it is also a good idea if you do so to use an ohm meter to check them as sometimes the fuse is bad but looks good. Let us know if you can give us a little more information to assist you.


You can see some examples of other thermostats available on this link.

Link to comment
Share on other sites

Reset the thermostat and see it that helps.


Turn the thermostat off, then hold the mode and zone button down. While holding the two buttons down turn the thermostat on. You are looking for FF, which means full function. If you see EE then that stands for electrical error.

When you try to use the thermostat listen for any relays clicking. I do no think you will but just listen.



Try that and get back to us today. Vern

Link to comment
Share on other sites

Tom, I have replaced several of those and they usually come with a wire diagram in the box. I got my replacements from Amazon but they are also available from Adventure RV for $31.53 plus shipping.


Since you have a Dometic thermostat, I'd bet that you also have a Dometic a/c unit as well. All six of the leads from the thermostat go to the a/c and connect to a control circuit board that is located there. They connect to that circuit board via a standard phone connector, RJ11. If there is no power to the air conditioner, nothing else will work either because the thermostat gets power from it. If you have 120V power to the a/c then the control board supplies the power to the thermostat as well as processing signals from it. Make sure that the a/c circuit breaker is closed by opening it completely and then resetting it again. It can be difficult to know for sure that it is tripped visually. As to the furnace operation, it is 12V-dc from the coach system and has no circuit breaker to check by may have a fuse. Since the a/c isn't working, there is very little chance that there is any problem with the furnace.

Link to comment
Share on other sites

Did you check the circuit breaker for the AC? The furnace is a separate box than the A/C, if I understand your connection of the two. The furnace has its own fan separate from the rooftop A/C fan. I had one start tripping in my first rig, and it looked like it was on at a quick glance. Unplug your RV from all outside power and flip every AC circuit breaker on and off and then plug in and try again. If you want to test the thermostat just flip it to heat and set it very high. If the furnace gas kicks in and then the fan when it reaches temperature the furnace and the thermostat are OK

Link to comment
Share on other sites

Are you looking at the same thing as I am?


4.3 Change Over Thermostat 59146. Only
The Change-over thermostat is a capillary tube/bellows-type switch. Its function is to allow the compressor/fan to operate only when outside ambient is 40° F.
+/-0 % or warmer.
A defective change-over thermostat can keep the compressor/fan from operating in the COOL or HEAT
PUMP modes.
To check the change-over thermostat, first verify the air temperature at the capillary tube. If the tempera
-tures are above 45° F., continuity should be between terminals 2 to 3 and no continuity between terminals
2 to 1. For temperatures below 40° F., continuity should be between terminals 2 toand no continuity between terminals 2 to 3. The change-over thermostat will break continuity on the white (common) wire when the outside temp reaches approximately 40° F..
No operation at all from the Heat Pump

It should be on the inside cooling coils, usually accessed from the inside of the RV, up inside of the interior grill.

Link to comment
Share on other sites

Thanks everyone. I have never had a problem with any of our RV AC units so this was a learning experience. The problem is an open black (hot) wire between the circuit breaker and the control board. It's open in the ceiling somewhere. Ran a quick temp wire and everything worked ok. Thanks Again. Tom

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

This topic is now closed to further replies.
  • Create New...