Jump to content

Trouble in Paradise


adept99

Recommended Posts

Several days ago we had an issue with our primary fuel filter to the point the truck would not start and run. Fast forward past a service run and up to today. Packed & ready, starting the truck to hookup and leave. No start, no run, no fun. Finally found a crack in the filter head - none in stock anywhere. Found one at a junk...er, recycler's yard. Installed that. Could not get a good prime. Tech on the way. We'll see ya'll tomorrow hopefully.

 

I love our truck (mostly)

 

Paul & Paula

Paul & Paula + Daisy the amazing wiggle worm dog...

2001 Volvo 770 Autoshift, Singled, w/ Aluminum Bed - Toy Draggin

2013 395AMP XLR Thunderbolt Toy Hauler

2013 Smart Passion

2012 CanAm Spyder RT

2013 Harley Davidson Street Glide

Link to comment
Share on other sites

Paul,

 

I had a similar problem on our Mack. Chased it for way too long. It turned out to be the o-ring on the cap of the Davco filter.

 

Good luck.

KW T-680, POPEMOBILE
Newmar X-Aire, VATICAN
Lots of old motorcycles, Moto Guzzi Griso and Spyder F3 currently in the front row
Young enough to play in the dirt as a retired farmer.
contact me at rickeieio1@comcast.net

Link to comment
Share on other sites

Hopin' you can get her going. Rally is revving up.

2006 Volvo 780 "Hoss" Volvo D12, 465hp, 1650 ft/lbs tq., ultrashift

Bed Build by "JW Morgan's Custom Welding"

2017 DRV 39DBRS3

2013 Smart Passion Coupe "Itty Bitty"

 

"Don't go around saying the world owes you a living. The world owes you nothing. It was here first!"

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

RVers Online University

campgroundviews.com

RV Destinations

Find out more or sign up for Escapees RV'ers Bootcamp.

Advertise your product or service here.

The Rvers- Now Streaming

RVTravel.com Logo



×
×
  • Create New...