Jump to content

engine brake not working


chevy3500

Recommended Posts

2000 Kenworth t2000: My engine brake wont activate, switches are on steering wheel (smart wheel) and has indicator lamp on upper dash. Neither the light or actual engine brake will work, any one know where to start looking? could not find a fuse that that was labeled for it in fuse box, there is a relay labeled "ABS engine brake" but replaced that with known working relay and no change. This seemed to quit working while driving and had been working fine.

Any help would be appreciated

Thanks!

Link to comment
Share on other sites

Jake needs a closed contact on the clutch pedal, a closed signal from the air brake pressure switch, a power signal from the dash On/Off switch, and a signal from the ECM that the throttle has no, zero, none pressure on it. The power signal appears to be getting through, as the dash indicator...indicates. Our T2 has problems with the air brake switch and corrosion. At least once a year, reach up under the dash from the ground. Wiggle the wires, good for another year. The first indication of corrosion is the cruise control randomly dropping out.

I have been wrong before, I'll probably be wrong again. 

2000 Kenworth T 2000 w/N-14 and 10 speed Gen1 Autoshift, deck built by Star Fabrication
2006 smart fourtwo cdi cabriolet
2007 32.5' Fleetwood Quantum


Please e-mail us here.

Link to comment
Share on other sites

My bad, I misread that the lamp was working. If the cruise is working, it has to be the switches on the steering wheel, or the connections to the ECM. The clutch switch and brake switch would also affect the cruise.

I have been wrong before, I'll probably be wrong again. 

2000 Kenworth T 2000 w/N-14 and 10 speed Gen1 Autoshift, deck built by Star Fabrication
2006 smart fourtwo cdi cabriolet
2007 32.5' Fleetwood Quantum


Please e-mail us here.

Link to comment
Share on other sites

You might get lucky, hit all the switches over and over. KW's tend to get corrosion in the weirdest places, and that plays havoc with the controls. I'm hesitant to recommend contact cleaner around the plastic of the steering wheel, but it can be useful, if you're very careful.

I have been wrong before, I'll probably be wrong again. 

2000 Kenworth T 2000 w/N-14 and 10 speed Gen1 Autoshift, deck built by Star Fabrication
2006 smart fourtwo cdi cabriolet
2007 32.5' Fleetwood Quantum


Please e-mail us here.

Link to comment
Share on other sites

  • 2 weeks later...

Thanks Scrap and Darryl. I've been on vacation so haven't looked at it much, did take the switch out but didn't see any obvious issues. Its a small module with 4 micro switches, (2,4,6 cylinders and off) can hear them clicking on and off, I know that don't mean anything, but maybe with the Scraps manual I can test it. Did attempt hitting switches repeatedly, as you suggested but no luck, Darryl. 

Before starting to pull things apart, where is the electronics module located? under dash or on steering column.

Thanks again!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
RVers Online University

mywaggle.com

campgroundviews.com

RV Destinations

Find out more or sign up for Escapees RV'ers Bootcamp.

Advertise your product or service here.

RVTravel.com Logo



×
×
  • Create New...