Jump to content

Hydraulic Jack's not working

Jim B

Recommended Posts

I have a 2000 Damon Intruder with about 93,000 miles.

Has not been used much the last few years. Used it Memorial day weekend and the Jack's worked fine. 

Took it out last weekend Jack's would not work at all. They are kickdown Jack's. When I use the control to actuate the Jack's nothing happens, not even a click. There is voltage at the solenoid terminals when activating the control. There is also voltage at the heavy wire on the input. No voltage at the output of the solenoid. Used a jumper cable to bypass the solenoid, pump still did not run.

Can anyone think of anything else that might be the problem other than the pump itself?

Any other tests anyone might suggest?

Thank you

Jim B

Link to comment
Share on other sites

Call Paul Maddox at 602 549 3638.  He posts his number on other RV forums so I am sure this is ok. He does troubleshooting for HWH, and is very knowledgeable on HWH systems. He lives in Arizona, and when you call leave a message as he doesnt answer hang ups.
Good luck

Edited by pjstough
Link to comment
Share on other sites

Researching on the internet, I found this operator's manual from HWH for the 225 series leveling system that looks like the same panel that you have. 


Check that out and see if it has anything that is helpful. Also, did you check the 5A fuse that is on the control panel? If possible, check it with an ohm meter as a fuse can be open and still look good. Here is a service manual that looks like it could be the right one.


Does the power on light come on when you turn the switch to on position? If you look at the service manual linked, on page 14 in part 7 of the manual it gives steps to troubleshoot the motor. 


Edited by Kirk W
Link to comment
Share on other sites

Thank you for your inputs:

The fuse on the joy stick was OK. The light on the joy stick panel did not come on when the switch was turned on.

Found a lead under the dash that had become disconnected from the fuse block. Did not see any way to reinsert the connector to the fuse block.

In an attempt to see if the pump would run I used a jumper cable to connect the batter directly to the pump motor. Got a big arc when I connected to the battery.

Today I connected the disconnected lead that became disconnected from the fuse block to another source of 12 volt power. Light on the joy stick panel now comes on.


I can hear the solenoid clicking but the pump did not run. Found the lead to the pump hot and the pump itself warm. I do not see how connecting the battery directly could have destroyed the pump motor.

Did I destroy the pump motor when I connected the battery directly to the pump motor? I would not think so.

Any other thoughts? Can the pump motor be replaces separately, or do I have to replace the entire pump system?

I will try calling Paul this week.

Thank you all for your help







Link to comment
Share on other sites

3 hours ago, Jim B said:

Did I destroy the pump motor when I connected the battery directly to the pump motor?

Without being there to see exactly what you did and to then check things with my volt/ohm meter, I will have to guess to answer the question. A big arc is never a good thing so it could have been because the motor was already bad or that you connected it to the wrong place. If the motor windings were somehow already shorted it could cause the arc but connecting anything directly to a charged battery without any kind of fuse is always risky at best. The fact that the motor got warm when you tested things after restoring power to the panel would seem to indicate that it was receiving power but is not operable. All I can tell you is that in my many years of electrical service work, I have replaced many parts that were damaged when the owner worked on them and more than a few times a motor was destroyed. If you read the troubleshooting section on the pump motor operation of the manual in the link, it indicates that the motor has an internal ground so if you applied the battery to terminal 2 it would have been directly to ground and so the big arc. They don't give any particulars on the internal parts of the motor so without taking readings with a meter I can only guess what might be wrong. It could even be that the pump is seized up and so the motor can't turn it. 

Link to comment
Share on other sites

  • 1 year later...

Did you ever get it figured out? I have a 94 winnebago adventurer with the same system, and mine the lights come on, but nothing else happens. I looked at the manual that was posted but I wasn't able to get anything else to happen no matter what I tried.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...