Jump to content

Garmin nuvi2689LMT will not connect to to laptop USB ports

Recommended Posts

I have a Garmin nuvi 2689LMT and it connects to my old laptop via USB with no problems - but time to retire that laptop.

I bought a new HP 15 inch laptop with 2 USB3 and 1 USB2 ports. The Garmin will not connect - The Garmin comes up with e message that it cannot charge and to use the supplied Garmin cable. - but that is what I am using. I also tried several other USB cables all with the same problem. Unless the Garmin is detected (and mounted as an external storage device) I cannot access it with Garmin Express to update it.

To summarise - the Garmin connects to my old laptop (USB2 only), but will not connect to any ports on the new one.

Other devices, such as a thumb drive, External hard drive and USB headset all connect to the USB on the new laptop.

Garmin support says it is a HP problem.

HP support says that if other devices work on the USB ports, it is not their issue.






Link to comment
Share on other sites

I had that problem with my Rand McNally gps it took about a year calling Dell and Rand McNally but I finally got a tech at Rand McNally who knew what the problem was took remote access and fixed the problem. it was a setting he knew about that fixed it. 

Link to comment
Share on other sites

as noted in my OP, I tried several cables. No improvement.

One suggestion on the POI factory is a voltage problem - late model GPS need more power, and newer laptops USB ports are lower than previous. So one suggested solution was to buy a powered USB hub. Yet Garmin says not to use a hub. Don't want to spend money if it will not solve the problem.

To Mike54 - do you know what the Tech changed?


Link to comment
Share on other sites

Here is an update  on my Nuvi to HP USB problem.

I took my GPS  into Bestbuy, where I bought the laptop and did an experiment (with the store's permission).

I plugged the GPS into an identical model HP laptop and it also failed.

Then plugged it into three late model but different HP laptops. It failed in each one.

Then I plugged the GPS into an Acer, Dell, and Levono late model laptops and it worked in each case.

So my conclusion is that there is an issue in the USB device manager on the current HP laptops that I tested.

I'll report to Garmin and to HP to see what happens next.


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...