bigjim

help firefox access

3 posts in this topic

Been on line almost all day on firefox   Got off for a while.  When I try to open it now I get a box with an X in a circle and it says "couldn't load XPCOM.  I tried doing a recovery to an earlier date, in doing so I saw there was supposedly a critical update earlier today.  I was still unable to open firefox.

I am accessing rvnetwork using IE which I don't care for at all.

Edited by bigjim

Share this post


Link to post
Share on other sites

Do a search (on Google or other search engine) for "firefox couldn't load XPCOM"  -- found several responses with solutions.

Share this post


Link to post
Share on other sites

DavidMc, I owe you the big one.  I never thought of looking for help on youtube or doing a google search.  I just hate it but I have never had an apptitude for computers. one suggestion was to totally uninstall  firefox and reinstall and I did think about that but didn't trust my judgement.

PS I accessed through Chrome this time and did find it far better than IE at least in this short usage.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

Dish For My RV Military Offer.

campgroundviews.com

Our program provides accurate individual wheel weights for your RV, toad, and tow vehicle, and will help you trim the pounds if you need to.

Find out more or sign up for Escapees RV'ers Bootcamp.

Advertise your product or service here.