Jump to content

Gen 1 1999 650k miles Cummins ISM electrical problem


bags
 Share

Recommended Posts

Our first real electrical gremlin has invaded our truck. I started the truck and every warning light came on. Shut down, caution, red light on temp, fluid levels etc. Turned it off and they went away so I took a drive and noticed my temp light was on and my gauges worked sporadically. No speedo, fuel, temp etc but I did have air pressure gauges. I subsequently got the truck back home hooked up my VMSPC (silver leaf electronics) and all pressures and temps were good even though my dash lights and gauges said differently. Shut down light was still on but truck never shut down and it had plenty of time too. I used my power probe to check all the fuses and they are good. Now my speedo pegs at 80 instead of powering up on start and then dropping back down. My computer says the truck is fine but it will drop out and then reconnect. Always before when it dropped out I had to close the program and re open. I disconnected the ground lead to the battery over night hooping that would clear it up but no luck. Does anybody have any ideas. Any and all information greatly appreciated.

Safe travels

John Bagley

Link to comment
Share on other sites

That's a headscratcher, for sure. I'd start with the connections at the back of the gauge cluster, also checking the grounds for the dash while the cluster is out. I don't remember what truck you have, but Gen 1 Volvo's have had solder issues on the gauges. Check the back of your gauge cluster for questionable solder points, while it's out. Let us know what you find.

Link to comment
Share on other sites

Also, you might check the connections from the dash harness to the gauge cluster. Wiggle them gently to see if that helps. Applying some Caig DeoxIT to the connectors might also help. A little goes a long way here and it needs to get down into the connector. DeoxIT is a contact enhancer. Good luck. Jay

Link to comment
Share on other sites

My mechanic has checked all cluster connections are good on this 15k milage cluster. he is supporting a ground issue as well. The ecm under the hood is working as it should, not throwing codes. We think there must be a second eco for the inside the truck for the cluster but can't find it. Anybody know anything about a second icm. There are 2 driver display fuses. I hate to take it to a dealer as my experience is the age of these mechanics is younger than the truck. Any and all thoughts appreciated. JB

 

Link to comment
Share on other sites

12 minutes ago, bags said:

My mechanic has checked all cluster connections are good on this 15k milage cluster. he is supporting a ground issue as well. The ecm under the hood is working as it should, not throwing codes. We think there must be a second eco for the inside the truck for the cluster but can't find it. Anybody know anything about a second icm. There are 2 driver display fuses. I hate to take it to a dealer as my experience is the age of these mechanics is younger than the truck. Any and all thoughts appreciated. JB

 

On my 1999 VNL there is only one ecm. Jay

Link to comment
Share on other sites

There are 2 fuses for the ECM as well.  One about a foot back on the main ECM harness, and another near the batteries- that one goes to ground.  There is a ground behind the lower dash panel by the steering column, and well as the main pass thru harness. There is also a ground that runs from the starter to frame.  I've replaced these as I've had issues with my "98 610.

Link to comment
Share on other sites

Thats great information. Thank you very much. My mechinic verified all grounds to dash cluster were good. checking those other grounds out sounds a real good lead as well. Thanks for all the help. JB

 

Link to comment
Share on other sites

  • Phil D changed the title to Gen 1 1999 650k miles Cummins ISM electrical problem

Your air pressure gauges come from a different module. 

The other gauges, water temp oil pressure etc, come from the ECU. 

I would more suspect communication issues between the ECU and the cab. 

I have seen on more than once the engine harness will have a broken wire from not being secured properly and vibrations will cause a wire to break. 

I am not a volvo guy, but have worked on lots of others. 

Link to comment
Share on other sites

The gen 1 dashes are known for bad solder joints. Send it out and have it all resoldered and then go from there. The dash uses serial data from the engine ECU to give it directions. The connector where this is soldered to the board is a known weak point.

Link to comment
Share on other sites

I had same issue about 3 years ago on our 1997 WIA 64 while camping at Myrtle Beach. Found a truck shop there and the owner and his two mechanics weni over every ground on the engine and in the dash. Cleaned them all and Deoxed.  No problems since.

Link to comment
Share on other sites

1 minute ago, chief916 said:

I had same issue about 3 years ago on our 1997 WIA 64 while camping at Myrtle Beach. Found a truck shop there and the owner and his two mechanics weni over every ground on the engine and in the dash. Cleaned them all and Deoxed.  No problems since.

Forgot.....I have a Detroit 60 11.1.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

RVers Online University

campgroundviews.com

Our program provides accurate individual wheel weights for your RV, toad, and tow vehicle, and will help you trim the pounds if you need to.

All the water you need...No matter where you go

Country Thunder Iowa

Nomad Internet

Rv Share

Dish For My RV.

RV Air.

Find out more or sign up for Escapees RV'ers Bootcamp.

Advertise your product or service here.

The Rvers- Now Streaming

RVTravel.com Logo



×
×
  • Create New...