Jump to content

Propane from one tank not working


Recommended Posts

This is a used 2016 Montana 3950BR with 30lb propane tanks on each side, internal compartments. Only the side with the valve to switch between tanks gets flow. 

Both tanks have plenty of propane. I've actually swapped tanks with the same result. Tank valves are open. 

Works with the tank on this side and selector valve switched to this side. Turns green as expected.

tank1.jpg

The other side gets no flow at all when switched and it goes red. I also noticed a green regulator on that side as well. Is it supposed to have a regulator on that side? Maybe bad regulator?

tank2-2.jpg

Thanks for any help?

Link to comment
Share on other sites

 Has it every worked properly? If not that would be my assumption too. Are you sure that regulator is  original equipment, it appears to be aftermarket added. I've never seen 2 pressure regulators when the dual regulator is installed.

Your first picture shows a dual regulator just like my last 5er had, but my cylinders were together.

Edited by Ray,IN
Link to comment
Share on other sites

Most RVs with tanks on opposing sides have a medium pressure regulator on the off-side. The NFPA has something about the requirements, but I'm too lazy to look them up. Step 1; Make sure there's gas coming out of the hose going into the switching regulator. The failure rate for the switching valves seems to be higher than any other part in the supply system, but that's just anecdotally.

Link to comment
Share on other sites

   I have seen that single regulator go bad and not pass gas. I had one a few weeks ago that was doing the same thing on a customers problem.

  Replace that regulator and it should work fine.

 

 

  Vern in a T-shirt 

Link to comment
Share on other sites

I had one that acted that way once. I disconnected and re connected a few times and then turned the tanks valve on SLOWLYYYYYYYY which for some reason made it start working properly ??????? I could hear a snap/change/toggle in the assembly which seemed different if I opened the tank slow????????? 

 

John T

Link to comment
Share on other sites

14 hours ago, sheldons65 said:

This is a used 2016 Montana 3950BR with 30lb propane tanks on each side, internal compartments. Only the side with the valve to switch between tanks gets flow. 

Both tanks have plenty of propane. I've actually swapped tanks with the same result. Tank valves are open. 

Works with the tank on this side and selector valve switched to this side. Turns green as expected.

tank1.jpg

The other side gets no flow at all when switched and it goes red. I also noticed a green regulator on that side as well. Is it supposed to have a regulator on that side? Maybe bad regulator?

tank2-2.jpg

Thanks for any help?

Switch the hose that go to the tank with the the other side. There is a check valve in the end that goes to the tank and they can fail on the closed position. 

Denny

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...