Jump to content

N14 Cummins Jake Has Issues


JPL
 Share

Recommended Posts

I have a 1998 VNL with the N14 Cummins and have had it since 2011. The Jake has always come on whenever I lifted off the throttle if it was on. Now with it on and I lift it doesn't come on. Sometimes it will but usually no Jake. Does this sound like a electrical issue? Any help/ideas are welcome!   Thanks      Pat

 

 

The Old Sailor

Link to comment
Share on other sites

My 95 Volvo WIA has a Detroit 60 series. 3 position Jake switch. Was going thru a small town in Oklahoma last year, put Jake in position 1 to keep it quieter. Later out on the highway put Jake back to position 3, went to slow down but only had 2 cylinders of Jake instead of all 6. When we got home I cleaned the 3 position switch with some LPS Electrical Contact Cleaner. Jakes work fine now. Switch was just dirty. Hope this helps. Mark

Link to comment
Share on other sites

Multiple points to fail on the Jake circuit.

1. Dash switch(es). As above, plus the contacts on the On/Off switch.
2. Brake pedal switch. There will be 2 switches on the air line from the pedal. One, Normally Open, to turn the brake lights on, one, Normally Closed, to turn the Jake off. This can be tested by shorting the wires together, and function testing.
3. Clutch Pedal switch. NC switch on the clutch pedal arm. Again, test by shorting the wires.
4. ECM controlled engines won't turn the Jake on until the engine makes a minimum temperature. A flaky temp sensor will be identified by the gauge being low, or erratic. Mechanical engines count on the driver to be judicious with the Jake until up to temp.

Edit to add: 5. Throttle position sensor. Older engines have an actual switch on the pedal arm, The N 14 is a "drive by wire" engine, so a reostat is used to let the ECM know throttle position. This is a long lasting part, so it's on the end of things to check. If the engine speed wanders while driving, move it up the list.

Edited by Darryl&Rita
Link to comment
Share on other sites

A&J    I do have a super 10 so I'll try that.

M&B   I will get some electrical cleaner and try that.

D&R    You have given me a great list to check and I will go thru that list. 

T o all thanks for the info and things to check. Now if one of them will only help!   Thanks Again, Pat

 

 

The Old Sailor

Link to comment
Share on other sites

  Just a thought that Darryl had on the throttle position sensor may help.

 

 I replace different sensors and parts as I have cash in my pocket or feel I need. I do buy stuff online at times.

 

 So three years ago I had purchased a throttle position sensor for our N14 cummins. During the summer. Now the truck was running good, but just thought I might replace that part. Now I always worry that when I do work on electronic stuff that it will not work.

 So now it is after New Years and I think I might put that part on. Three mounths till I really need the truck. So I replace the sensor and try to start the truck. It stated what I thought was better than before. Ok now drive the truck and it acts like it has better response. Just was not thinking it would make any difference. So I was not really paying attention to how it was running before.

 

 So we leave for summer travels in the spring and I notice the cruise control is working better. Now we purchased this truck in 07, it is a 2000 VNL and the cruise would waite till it really needed throttle to catch up to speed when it was on a decent grade. I just got use to helping the throttle on those grades. 

 Now it works the way it should.

 

 Just a thought,.   Vern

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...