Jump to content
jwil1208

RV Service in Olympia, WA area recommendations?

Recommended Posts

Looking for a reputable professional RV Service/repair facility in the Olympia/Lacey, WA area.  Your recommendations are appreciated.  Thank you.

Share this post


Link to post
Share on other sites

We have an Arctic Fox 5th wheel.... need minor things done as well as a MAJOR question solved:  why won't the (black & grey) tanks drain!!!??

 

Thanks for all your ideas.

Share this post


Link to post
Share on other sites
8 minutes ago, jwil1208 said:

... need minor things done as well as a MAJOR question solved:  why won't the (black & grey) tanks drain!!!??

 

If neither tank will drain my first question is, are you assuming that the tanks aren't draining because the gauge shows them to be full or partially full? RV tank gauges are of the cheapest type available in most brands and those rarely work for very long. The level is sensed by several metal buttons extending through the tank wall and sense a small electric current between the different sensors to indicate level. Once the tanks have been used a few times there is a residue left on the tank walls that will conduct electricity, especially when wet. That causes the tank levels to be wrong and often to show completely full. 

It could be that you do have some sort of blockage so if your tanks are actually full to where the sink doesn't drain and things back up into the shower, and if you can see into the black tank with a flashlight and it is full, then you have a different issue. While tank drain problems do happen, I can't remember the last time I heard of a problem that blocked both tanks. Let us know which problem you have and we can likely help.

Share this post


Link to post
Share on other sites

The type of sensor you have depends on the age and quality level of 5th. Some sensors are on the outside of the tank but what Kirk says is true. I wouldn't put too much trust in the sensors and I have never heard of both tanks being blocked, unless frozen.

Share this post


Link to post
Share on other sites

Why don't you give us a list of your problems? We are a handy bunch and may have some solutions that you will be able to do yourself.  Save some $.

Share this post


Link to post
Share on other sites

Do your grey and black tanks drain through a single valve?   It is possible a piece of the hole cutout for one of the tanks is blocking it.  Keeping the black closed, put a bucket under outlet and slowly open gray tank - if nothing coming out, try a short snake-like rod up to see if you can feel the blockage.

Share this post


Link to post
Share on other sites
13 hours ago, jwil1208 said:

We have an Arctic Fox 5th wheel.... need minor things done as well as a MAJOR question solved:  why won't the (black & grey) tanks drain!!!??

You didn't mention the year or model, but a lot of Arctic Fox's have electric drain valves.  Is this a brand new rig?  Have you ever successfully drained the tanks?

Since (apparently) both the grey & black are not draining, I would suspect a blown fuse, dead coach battery,  bad switch, or loose/disconnected switch wire.

Share this post


Link to post
Share on other sites

Take it to Mike and Dave at Southend RV Repair in Tacoma.
They fixed my Schwintek slideout when no one else could.  I witnessed major teardowns and a roof replacement during my visits to their shop.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×