Jump to content
Sign in to follow this  
StarlifterFE

2005 HR Ambassador Water Pump Inop

Recommended Posts

2005 Holiday Rambler Ambassador

Water pump quit working.  RV mechanic checked the fuse in coach and it's good.  There is power to the switch.  No power at the pump.  He said that there is a control box in the system somewhere but he doesn't have a clue where it's at.  He looked at all of the places where it might be located with no luck.  And, there is no inline fuse by the pump.  Does anyone have any idea where the control box or the inline fuse might be located?  Thanks in advance for any help.

Barry

Share this post


Link to post
Share on other sites
3 hours ago, StarlifterFE said:

He looked at all of the places where it might be located with no luck. 

I sure hope that he didn't charge for this failure? It is time to get out a meter and trace the circuit to see what is between that switch and the pump. 

Share this post


Link to post
Share on other sites
On ‎1‎/‎9‎/‎2018 at 5:55 PM, Kirk Wood said:

I sure hope that he didn't charge for this failure? It is time to get out a meter and trace the circuit to see what is between that switch and the pump. 

Can never figure why people  don't invest in a light powered tester. Its not rocket science boys and girl. A multimeter is also handy with a conduity feature but for a few bucks can buy a light powered one. There great for testing bulbs for being good. If its 12volts the ground is usually the culprit on anything in the elements.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×