Jump to content

Search the Community

Showing results for tags 'challenger'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • RVing Forums
    • Beginning RVing
    • General RV Information
    • Sharing the Fulltime Lifestyle
    • Graduating to Fulltime
    • Technical Tips and Tricks
    • Internet Access on the Road
    • Satellite TV and Radio on the Road
    • RVing on a Budget
    • Working on the Road
    • Volunteering Adventures
    • Day's End
    • Travel
    • Boondocking
    • RV Housekeeping
    • RV Action Items
    • Travel Logs
    • Escapees RV Club Events
    • Road to Escapade
    • RVing With Pets
    • RVing Families
  • RV Types
    • Class A
    • Class B
    • Class C
    • Fifth-Wheel
    • Travel Trailer
    • MDT
    • HDT
    • Bus Conversions
  • RV Marketplace
    • RV Rig Exchanges
    • RVs, Tows, and Toads for Sale
    • RV Accessories for Sale
    • RVs (And Accessories) Wanted
    • Workers Wanted
    • RVers Looking for Work
    • RV Sites/Lots/Memberships for Sale
  • Other Subjects
    • RVillage
    • Computers and Software
    • Amateur Radio
    • Activities and Hobbies
    • Veterans
    • Finances and Investing
    • Health Issues and Medical Insurance
    • Recipes
    • Other Topics
  • Site and Forum Operation
    • About the Discussion Forums
    • Bugs and Feature Requests
    • Test Posts

Calendars

There are no results to display.


Found 2 results

  1. I have a 2015 Thor Challenger 37ND. I'm having electrical problems in the bedroom outlets. The problem was identified when devices plugged into the bedroom outlets started coming on and off. They would be on for about 60 sec, then go off for a few seconds. Then stay on for a few minutes then go off for 30-40 secs (times are not exact). A day later there is no power. I've checked breakers and fuses and all is as it should be except no power. I've identified that it affects three outlets in the bedroom (except the one the TV is plugged in to) and now outlets on the left side of the RV and the bathroom GFCI outlet. I'v learned that the 3 bedroom outlets and 2 outlets above the sofa on the left side of the RV are wired together. Any suggestions?
  2. Atwood Water Heater

    I have an Atwood water heater propane/electric GC6AA-10E. I'm not receiving a light on the display panel and the electric ignition doesn't work but the propane does. I've changed the ECO & TSTAT sensors. Still I get no panel light inside or electric ignition, only propane ignition. Anyone have an idea what my problem may be?
×