Jump to content

tiny

Validated Members
  • Content Count

    6
  • Joined

  • Last visited

Everything posted by tiny

  1. tiny

    12v Issues

    First off I apologize if this topic has already been covered, but I am on time crunch. I have a 1996 sportsman trailer. I got it this summer and it has worked fine. Last night I went out to get it ready for the wife to take on a trip, and none of the 12v system seems to be working. When I plug into the power on my house the microwave and all the outlets work, but the lights still do not. Also the refrigerator and furnace do not work. The battery is brand new and completely charged. The first time I turned on the lights one lit up very dim for a couple of seconds and then went out. I replaced all the fuses and turned all breakers on and off. There isn't much to this trailer so I am thinking I can fix it if I knew what it could be. I have no manual and nobody to lean on for answers. I saw something online about circuit breakers, but I am not sure where to look for them. Help me if you can. I appreciate your patience in advance. TC
  2. tiny

    12v Issues

    I got it all working. No way would I have been able to do it without the wisdom of you all. I look forward to reading this forum for fun. instead of panic.
  3. tiny

    12v Issues

    I will change the 20 amp out tomorrow. I also bought a multi tester and will mess around with it tomorrow. I unhooked the battery and brought it in the garage to charge again. I hooked the battery up with the ground on negative earlier so I think it is right. And if I flipped it around the posts would be backwards so I know that is right. Isn't it weird that the radio works and nothing else? I will keep checking back for your wisdom, and continue to try to figure out what I am doing wrong. And I will learn to use the multi tester. Thanks, Tiny
  4. tiny

    12v Issues

    By the way, what are SKPs?
  5. tiny

    12v Issues

    I replaced two breakers under the front of the trailer. (I think only the 15 amp one was bad.) Went inside and the radio will turn on but nothing else. One was a 40 amp and one was a 15, but I replaced it with a 20amp because I didn't have a 15. It is not plugged into shore power. I checked the battery on the guage inside the trailer and it registered @ 2\3. Yesterday it said full, so it seems like something is drawing juice. I will look at the information you provided and get after it again tomorrow. I got home late today. Thanks for sticking with me. I will learn this as well as the proper terminology for what I am trying to talk about. Thanks again Tiny
  6. tiny

    12v Issues

    It is a brand new battery. I charged it in the garage and when I tested it with a cheapo tester it hit the max. I do not know what a battery isolation device is or where to look. I am sorry for my ignorance. I will also try the sanding the ground trick. As well as locating the two cable post and checking it. I am at work so I won't be able to do it for a while, but I am thankful that someone out there willing to help. Thank you again!!! Tiny
×